Tutorial de Timestamps con Google Sheets Usando la Función LAMBDA

¡Hola y bienvenidos a un nuevo video tutorial de Google Sheets en Juan Guzmán! Hoy vamos a explorar cómo crear timestamps de una manera confiable utilizando la nueva función LAMBDA en Google Sheets. Este método es especialmente útil para seguimientos de documentos, control de asistencia, y más. A continuación, veremos paso a paso cómo configurar estos timestamps.

Introducción

Ejemplos de Uso

  1. Seguimiento de Documentos: Registro automático de la fecha y hora en que un documento es modificado.
  2. Control de Asistencia: Marca temporal al momento de chequear la asistencia de alguien.
  3. Escaneo de Productos: Registro de la hora exacta en que un producto es escaneado.

Vamos a realizar dos ejemplos:

  1. Timestamps al escribir un nombre.
  2. Timestamps al seleccionar una casilla de verificación.

Paso 1: Crear Timestamps con Nombres

Paso 1.1: Fórmula Básica con AHORA()

Primero, probemos la fórmula básica =AHORA():

=AHORA()

Esta fórmula proporciona la fecha y hora actuales, pero se actualiza constantemente cada vez que la hoja se recalcula, lo cual no es adecuado para un timestamp fijo.

Paso 1.2: Condicional con SI()

Podemos mejorarla usando =SI() para evitar que se actualice si la celda está vacía:

=SI(A2=""; ""; AHORA())

Pero sigue teniendo el problema de actualización constante.

Paso 1.3: Crear Función con LAMBDA

Para resolver este problema, usaremos la función LAMBDA:

Paso 1.3.1: Definir el LAMBDA

=LAMBDA(nombre, marca_tiempo, SI(nombre=""; ""; marca_tiempo))

Paso 1.3.2: Aplicar el LAMBDA

=LAMBDA(nombre, marca_tiempo, SI(nombre=""; ""; marca_tiempo))(A2, AHORA())

Esto fija el timestamp una vez establecido, evitando la actualización constante.

Paso 1.4: Uso de la Función en la Hoja

  1. Escribe cualquier nombre en A2 y verás el timestamp en B2.
  2. Prueba con varios nombres y observa que el timestamp se mantiene fijo.

Paso 2: Crear Timestamps con Casillas de Verificación

Paso 2.1: Insertar Casillas de Verificación

  1. Selecciona la celda donde quieres la casilla de verificación.
  2. Ve a Insertar > Casilla de verificación.

Paso 2.2: Fórmula con LAMBDA para Casillas de Verificación

Paso 2.2.1: Definir el LAMBDA

=LAMBDA(nombre, marca_tiempo, SI(nombre=FALSO; ""; marca_tiempo))

Paso 2.2.2: Aplicar el LAMBDA

=LAMBDA(nombre, marca_tiempo, SI(nombre=FALSO; ""; marca_tiempo))(A2, AHORA())

Paso 2.3: Uso de la Función en la Hoja

  1. Marca la casilla de verificación en A2 y verás el timestamp en B2.
  2. Prueba con varias casillas y observa que el timestamp se mantiene fijo.

Conclusión

Hemos explorado cómo utilizar la función LAMBDA para crear timestamps en Google Sheets de manera confiable y sin que se actualicen constantemente. Este método es ideal para registrar la fecha y hora exactas de eventos importantes en tu hoja de cálculo.

Espero que este tutorial haya sido útil. Si deseas más contenido como este, considera suscribirte al canal, unirte a la academia o apoyarnos en Patreon para acceder a más plantillas y cursos detallados. ¡Muchas gracias y nos vemos en la próxima!

Deja un comentario

Tu dirección de correo electrónico no será publicada. Los campos obligatorios están marcados con *

Este sitio usa Akismet para reducir el spam. Aprende cómo se procesan los datos de tus comentarios.

Pin It on Pinterest

Share This